Oops…Cry of "Wolf"

After applying SP2 on Sunday we had no real-time integration with the Luminis Message Broker (Sungard). I sent an email around to everyone, management, Luminis Admins, DBA’s…  I knew the SP contained an upgraded deployable component LMBadapter.jar that would wipe our our connection settings, so I re-entered them before testing. I checked the connection by toggling it true and false while tailing the webct.log.  I expected to see lines about connecting, something along these lines:

<log4j:event logger=”com.webct.platform.framework.ejb.TopicBase” timestamp=”1179146974835″ time=”Mon May 14 08:49:34 EDT 2007″ level=”DEBUG” thread=”VistaPooledThread-0:0″ schema=”LMS”>^M
<log4j:message><![CDATA[CLASS: com.webct.platform.framework.ejb.TopicBase METHOD: connect()^M
SUCCESSFULLY looked up topic Sun ONE MQ Destination
getName(): com_sct_ldi_sis_LmsSync
Class: com.sct.pipeline.jms.Topic
getVERSION(): 3.0
isReadonly(): false
getProperties(): {imqDestinationName=com_sct_ldi_sis_LmsSync, imqDestinationDescription=MessageBroker internal administered object}(cn=topic$com_sct_ldi_sis_LmsSync,ou=AdministeredObjects) using JNDI.]]></log4j:message>^M
</log4j:event>

Nada. Nothing was being recorded.

What do you think was wrong? (Warning: The answer is multifaceted.)

Clues:

1. A previous version of Vista had been subscribed to this LMB instance.
2. An xml file with enrollments edited on my Desktop did not import correctly. It was putting this error in the logs:

<log4j:message><![CDATA[CLASS: com.webct.platform.coreservice.systemintegrationapi.service.adapters.deployablecomponents.luminis.LMBAdapter METHOD: postProcess(ProcessingRecord record)
postProcess has been called for a record marked as UNPROCESSED]]></log4j:message>
</log4j:event>
<log4j:event logger=”com.webct.platform.coreservice.systemintegrationapi.service.adapters.deployablecomponents.luminis.LMBAdapter” timestamp=”1179765088333″ time=”Mon May 21 12:31:28 EDT 2007″ level=”ERROR” thread=”ExecuteThread: ’13’ for queue: ‘weblogic.kernel.Default'” schema=”LMS”>
<log4j:message><![CDATA[CLASS: com.webct.platform.coreservice.systemintegrationapi.service.adapters.deployablecomponents.luminis.LMBAdapter METHOD: postProcess(ProcessingRecord record)
An irrecoverable error occurred in record processing]]></log4j:message>
</log4j:event>

Advertisements

Comments are closed.